
MegaStat Installation Instructions 

1.  Download MegaStatInstallationFilesWindows.zip from the website.   

When you click the download link you will see options at the bottom of the screen that will depend on 

the browser you are using.   Do not click the Open option because you need to do the next step before 

opening and extracting.  Click the option that will save the .zip file in your Downloads folder and open 

the folder. 

                   The download contains the following files: 

 MegaStatInstallationInstructionsWindows.pdf (this file) 

 MegaStatInstallerWindows.xlsm (the installation workbook)  

 MegaStat.xlam (the program file)  

 MegaStat.chm (the help file)  

 TestData.xlsx (sample data referred to in the User’s Guide) 

 

2. Unblock MegaStatInstallationFilesWindows.zip. 

Right-click MegaStatInstallationFilesWindows.zip, click Properties, and you will see the following: 

 

                Check the Unblock checkbox and click OK.  If you don’t see the Unblock checkbox, click Cancel. 

Check the Unblock checkbox and 

click OK.  If you don’t see the 

Unblock checkbox, click Cancel. 



 

3. Extract the files from MegaStatInstallationFilesWindows.zip.  

Right-click MegaStatInstallationFilesWindows.zip and click Extract All…. Select a destination or note 

the suggested destination and click Extract. 

4. Open MegaStatInstallerWindows.xlsm from the location where you extracted the files. 

When you open the installer workbook you may be asked to click Enable Editing and Enable Content.  

You will need to have macros enabled in Excel to install and run MegaStat and the installer workbook. 

If you are not sure if macros are enabled, go ahead and try installing and see if you get any messages.  

If you need to enable macros do the following steps in Excel: File > Options > Trust Center > Trust 

Center Settings > Macro Settings > check "Enable all macros" or "Disable all macros with notification”.  

See the FAQ section below if you want more information about macros. 

When you open the installation workbook there will be an Install MegaStat button (see below).  Click it 

and the MegaStat files will be copied to the Add-ins folder and MegaStat will be placed on the Data 

ribbon. MegaStat will then be available whenever you open Excel.   

That should be all you need to do but take a look at the rest of this file for more information and how 

to efficiently use MegaStat.  You might want to print the home page of the installer workbook after 

installation as a reference for the file locations. 

 

The installer before clicking Install MegaStat: 

 

 



 

 

The installer after clicking Install MegaStat: 

 

If you prefer to install MegaStat without using the installer workbook there are manual installation 

instructions below. 

 

         MegaStat on the Excel Data ribbon after installation: 

 

 

 

Frequently Asked Questions about MegaStat Installation 

What would happen if I don’t do the Unblock step 2 in the installation instructions? 

MegaStat would probably install; however, it would not be on the ribbon the next time you use Excel.  

Also, the help system would not be available. 

If you have already extracted the files you can unblock MegaStat.xlam and MegaStat.chm individually 

by using the same procedure: right-click > Properties > check Unblock. 



What does it mean if the Unblock checkbox is not there? 

Either it was never there or the file has already been unblocked. 

Do I need to uninstall a previous version of MegaStat before installing this version? 

It is not necessary unless you have previously installed MegaStat from a location other than the default 

add-ins folder.  If that is the case, the installer will detect it and instruct you on how to proceed. 

To uninstall this version of MegaStat just delete the MegaStat files in the Add-ins folder or open the 

installer workbook and click Uninstall MegaStat. 

Do I need to keep the installer workbook and the installation files? 

You should not have to run the installation again but it would probably be a good idea to keep the 

installer workbook and other files.  You may want to use it for uninstalling. The installation files also 

include TestData.xlsx referred to in the User’s Guide and can be used to initially try MegaStat. 

The location of the installation files is shown in the installer workbook.  You could leave them there or 

copy them to another location. 

Can I do the MegaStat start-up without the installer workbook? 

Yes.  Start-up is just the procedure of putting MegaStat on the Data ribbon after the files have been 

copied.  The installer workbook does it with a program command but it can also be done as follows: 

File > Options > Add-Ins > click Go next to Manage Excel Add-ins.  Check MegaStat in the Add-ins list.   

Is it important to exit the installer workbook with the Exit Installation button? 

No.  Once MegaStat is added to the Data ribbon the work of the installer is done.  The button just 

closes it.  You can leave the file open; however, it is recommended that you exit the installer and open 

a new workbook before you start using MegaStat.   

Do the MegaStat files have to be in the Add-Ins folder? 

No. MegaStat can run from any folder as long as MegaStat.xlam and MegaStat.chm are in the same 

folder.  You would need to use Excel > Options > Add-ins and Browse to a location other than the add-

ins folder.  However, it is preferable to use the default add-ins folder. 

Is the MegaStat help file (MegaStat.chm) necessary to run MegaStat? 

No, but if the help file is not in the same folder as MegaStat.xlam none of the MegaStat help functions 

will work. 

What is a macro and why do they have to be enabled? 

A macro is a set of recorded instructions.  In the early days of Excel macros were just recorded 

keystrokes that could be repeated but eventually macros became instructions in the computer 

language VBA (Visual Basic for Applications).  Macros can still be recorded and if you use Excel much 



you should explore how to do that; however, VBA is a full featured programming language that can be 

used to create add-in programs far more complex than simple macros.  MegaStat consists of several 

thousand lines of VBA code.  Since MegaStat is technically a macro, macros have to be enabled for it to 

run.  You should be cautious about opening Excel files with macro content (.xlsm) or add-ins (.xlam) 

from sources you aren’t familiar with. 

Changing where MegaStat appears in Excel 

How do I put MegaStat on the Quick Access Toolbar? 

Putting MegaStat on the Quick Access Toolbar is recommended because it makes MegaStat easier to 

use since you don't have to click and Data ribbon every time you want to use it. Right-click MegaStat 

on the Data ribbon and there will an option to add it to the Quick Access Toolbar.  It will also stay on 

the Data ribbon. 

If you want to change MegaStat’s position on the Quick Access Toolbar, right click the Quick Access 

Toolbar and select Customize Quick Access Toolbar... 

How do I copy MegaStat to another ribbon location? 

MegaStat starts on the Data ribbon (and will remain there); however, it can be copied to another 

ribbon. You can even create a separate MegaStat ribbon.  You do this by right-clicking the ribbon and 

selecting Customize the Ribbon.  On the left section of the screen you will see Choose Commands from 

Popular Commands.  Click the drop-down and change it to All Commands.  There are a lot of 

commands but scroll down to MegaStat listed alphabetically about half-way through the list and click 

it. 

Then on the right section of the screen right-click at the location where you want MegaStat to be 

located and add & name a new ribbon or a new group.  Then click Add in the center of the screen. 

Experiment with it.  It is easier than it sounds and you may find other ways to customize Excel. The 

MegaStat User’s Guide has more detailed instructions. 

 

How can I remove MegaStat from the Data ribbon? 

There are two ways: 

1. From within MegaStat > Utilities > Remove MegaStat 

  

2.  File > Options > Add-Ins > click Go next to Manage Excel Add-ins.  Uncheck MegaStat in the Add-Ins list 

 

If you want to remove MegaStat from the Add-ins list, exit Excel and remove the two MegaStat files 

from the Add-Ins folder that was shown during the setup.  The next time you open Excel, MegaStat will 

not be on the Add-Ins list. Or you can open MegaStatInstallerWindows.xlsm and click Uninstall 

MegaStat. 



Manual installation instructions 

Here are instructions for manually installing MegaStat without using the installer workbook.  This might be 

useful in case you run into problems or just prefer doing things yourself.  Manual installation implies 

acceptance of the license agreement.  A copy of the license agreement is shown below. 

Step 1. 

Copy MegaStat.xlam and MegaStat.chm to the Add-ins folder: 

          C:\Users\{your_username}\AppData\Roaming\Microsoft\AddIns 

If you do not to see the AppData folder in your folders list you will need to do the following: File Explorer > 

File tab > Change folder and search options > View tab > click Show hidden files, folders, or drives. 

Step 2. 

Put MegaStat on the Excel Data ribbon with the following steps: 

1. Start Excel 

2. Click:   File → Options 

3. Click:  Add-Ins on the left menu list. You will now see a list of Excel Add-Ins.  MegaStat should be in 

the Inactive Application Add-ins list.             

4. Click:  Go... for Manage Excel Add-Ins near the bottom of the screen and the Add-ins window will 

appear. 

 

Click Go to see the Add-ins list. 



5. Click the check box next to MegaStat in the Add-Ins list unless it is already checked.  Click OK when 

MegaStat is checked. 

 

6. Click the Data ribbon.  MegaStat will be on the ribbon and ready to use.  MegaStat should be on the 

Data ribbon whenever you open Excel and should remain on the Data ribbon until you remove it. 

To uninstall, just delete the two MegaStat files from the Add-ins folder.  



 

MegaStat License Agreement 

IMPORTANT NOTICE 

Distributed by McGraw-Hill Global Education Holdings, LLC. 

Use of this product (the “Product”) is subject to the terms below (“License Agreement”) and any others that 

may be set forth in the Help or About menu of this Product.   

LICENSE AGREEMENT 

LICENSE:  Throughout this License Agreement, "you" shall mean either the individual or the entity whose 

agent opens this package.  You are granted a non-exclusive and non-transferable license to use the Product 

only on a single computer (i.e., a single CPU) for your personal educational purposes only, subject to the 

restrictions herein.    

COPYRIGHT; RESTRICTIONS ON USE AND TRANSFER:  All rights (including copyright) in and to the Product are 

owned by McGraw-Hill and its licensors.  You may not copy, decompile, disassemble, reverse engineer, 

modify, reproduce, create derivative works of, transmit, distribute, sublicense, store in a database or retrieval 

system of any kind, rent or transfer the Product, or any portion thereof, in any form or by any means 

(including electronically or otherwise), and may not use the Product except as expressly permitted herein.  

You must reproduce the copyright notices, trademark notices, legends and logos of McGraw-Hill and its 

licensors that appear on the Product on the back-up copy of the Product which you are permitted to make 

hereunder.  All rights in the Product not expressly granted herein are reserved by McGraw-Hill and its 

licensors.  

TERM:  This License Agreement is effective until terminated.  It will terminate if you fail to comply with any 

term or condition of this License Agreement.  Upon termination, you are obligated to return to McGraw-Hill 

the Product together with all copies thereof and to purge all copies of the Product included in any and all 

computer facilities.   

DISCLAIMER OF WARRANTY:  THE PRODUCT OF THE PRODUCT ARE LICENSED "AS IS." McGRAW-HILL, ITS 

LICENSORS AND THE AUTHORS MAKE NO WARRANTIES, EXPRESS OR IMPLIED, AS TO RESULTS TO BE 

OBTAINED BY ANY PERSON OR ENTITY FROM USE OF THE PRODUCT AND/OR ANY INFORMATION OR DATA 

INCLUDED THEREIN.  McGRAW-HILL, ITS LICENSORS AND THE AUTHORS MAKE NO EXPRESS OR IMPLIED 

WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE OR USE WITH RESPECT TO THE 

PRODUCT OR AS TO THE ACCURACY, COMPLETENESS, CURRENTNESS OR RESULTS TO BE OBTAINED FROM THE 

PRODUCT.  NEITHER McGRAW-HILL NOR ANY OF ITS LICENSORS OR AUTHORS WARRANT THAT THE 

FUNCTIONS CONTAINED IN THE PRODUCT WILL MEET YOUR REQUIREMENTS OR THAT THE OPERATION OF 

THE PRODUCT WILL BE UNINTERRUPTED OR ERROR FREE.  NEITHER MCGRAW-HILL NOR ANY OF ITS 

LICENSORS OR AUTHORS SHALL BE LIABLE TO YOU OR TO ANY USER OF THE PRODUCT OR ANYONE ELSE FOR 

ANY INACCURACY, ERROR OR OMISSION, REGARDLESS OF CAUSE, IN THE PRODUCT OR ITS CONTENTS, OR FOR 

ANY DAMAGES RESULTING THEREFROM.  YOU ASSUME THE ENTIRE RISK WITH RESPECT TO THE QUALITY AND 



PERFORMANCE OF THE PRODUCT.  McGraw-Hill, its licensors and authors make no guarantee that you will 

pass any certification exam by using this Product.   

LIMITATION OF LIABILITY:  NEITHER McGRAW-HILL, ITS LICENSORS NOR THE AUTHORS SHALL BE LIABLE FOR 

ANY INDIRECT, SPECIAL OR CONSEQUENTIAL DAMAGES, SUCH AS BUT NOT LIMITED TO, LOSS OF ANTICIPATED 

PROFITS OR BENEFITS, RESULTING FROM THE USE OR INABILITY TO USE THE PRODUCT EVEN IF ANY OF THEM 

HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  THIS LIMITATION OF LIABILITY SHALL APPLY TO 

ANY CLAIM OR CAUSE WHATSOEVER WHETHER SUCH CLAIM OR CAUSE ARISES IN CONTRACT, TORT, OR 

OTHERWISE.  Some states do not allow the exclusion or limitation of indirect, special or consequential 

damages, so the above limitation may not apply to you.  

U.S. GOVERNMENT RESTRICTED RIGHTS:  Any software included in the Product is provided with restricted 

rights subject to subparagraphs (c) (1) and (2) of the Commercial Computer Software-Restricted Rights clause 

at 48 C.F.R. 52.227-19. The terms of this Agreement applicable to the use of the data in the Product are those 

under which the data are generally made available to the general public by McGraw-Hill.  Except as provided 

herein, no reproduction, use, or disclosure rights are granted with respect to the data included in the Product 

and no right to modify or create derivative works from any such data is hereby granted.   

GENERAL:  This License Agreement constitutes the entire agreement between the parties relating to the 

Product.  The terms of any Purchase Order shall have no effect on the terms of this License Agreement.  

Failure of McGraw-Hill to insist at any time on strict compliance with this License Agreement shall not 

constitute a waiver of any rights under this License Agreement.  This License Agreement shall be construed 

and governed in accordance with the laws of the State of New York.  If any provision of this License Agreement 

is held to be contrary to law, that provision will be enforced to the maximum extent permissible and the 

remaining provisions will remain in full force and effect. 

 

 

 

 

 


